Форумы  ·  Войти  · 

Тема: RTSP поток с IP камеры через SIP-CDA2 и  сервер Asterisk

09.11.21 7:51   31041  (6/09.11.21)  

Доброго дня.
У нас связка - домофон цифрал+SIP-CDA2+сервер Asterisk - звоним на телефон с приложением Linphone.
Обычный звонок проходит и все хорошо работает. Добавляем в SIP-CDA2 ссылку на RTSP с камеры, поток с самыми минимальными требованиями, но при вызове все равно идет аудио звонок и никак не тянет видео.

Вопрос, как понять что SIP-CDA2 - получил поток?
Возможно у вас есть рабочий кейс по такой связке? Подскажите может в астериске не учли настройку?

[ Изменено: 09.11.21 7:58 31041 ]
[ #1 ]  09.11.21 8:19   Reboot  KOMENDANT LAB  

В астериске должна быть обязательно включена в общих настройках поддержка видео. У всех внутренних номеров кодек H264. Если все эти настройки есть, чтобы определить причину, нужен дамп зеркалированного потока с CDA2 на компьютер с wireshark от начала до конца звонка. Вложите в форум. По нему все будет видно.

[ #2 ]  09.11.21 9:25   31041  (6/09.11.21)  

вложил ip адаптера 10.99.0.127

[ Изменено: 09.11.21 9:30 31041 ]
[ #3 ]  09.11.21 9:30   Reboot  KOMENDANT LAB  

Asterisk в 200 OK SDP отвечает video 0 RTP/AVP 97
Не выделил порт для видео, не готов принять либо клиент либо по настройкам астериску не положено.

[ #4 ]  09.11.21 14:02   31041  (6/09.11.21)  

Посмотрите еще раз.
Включили все кодеки, но видео все равно нет. Хотя теперь показывает видео звонок, но при ответе отбивает звонок.

[ Изменено: 09.11.21 14:09 31041 ]
[ #5 ]  09.11.21 14:18   Reboot  KOMENDANT LAB  

Ничего не отбивает. Со стороны адаптера разговор продолжается 45 секунд с аудио и видео, после чего звонок завершается корректно со стороны адаптера. Пакеты с видео не превышают допустимый размер. Только встречные звук и видео на адаптер почему-то не идут. Раньше шел звук.

[ #6 ]  09.11.21 14:19   31041  (6/09.11.21)  

да, раньше был звук

[ #7 ]  09.11.21 14:22   Reboot  KOMENDANT LAB  

Что-то поменялось. Возможно клиент отваливается, потому что видео высокого разрешения. Выключите видео в адаптере и сравните. Если звук будет односторонний, значит еще в чем-то причина.

[ #8 ]  09.11.21 14:28   31041  (6/09.11.21)  

Без видео все проходит. аудио звонок есть.

[ #9 ]  09.11.21 14:32   Reboot  KOMENDANT LAB  

Скорее всего видео для клиента слишком тяжелое. Попробуйте другой клиент или сделайте у камеры разрешение CIF и качество среднее, потом будете увеличивать. Звук в обе стороны?

[ #10 ]  09.11.21 14:37   31041  (6/09.11.21)  

я отключил камеру, но в настройках адаптера оставил ссылку и идет сбой.
голоса тоже нет. будем разбираться

[ #11 ]  09.11.21 14:38   Reboot  KOMENDANT LAB  

Достаточно было у адаптера рядом со ссылкой поставить настройку нет видео.

©1999-2021 Компания АТСН, РФ, Москва